XUPV2P, Kernel 2.6.17 boot problem

Benjamin Heyne benjamin.heyne at uni-dortmund.de
Mon Aug 14 19:10:14 EST 2006

And so it came to pass, that on Fri, 11 Aug 2006 23:37:25 -0500
Milton Miller <miltonm at bga.com> wrote as thus:

> On Mon Aug  7 2006 04:46:43 AM CDT, Benjamin Heyne wrote:
> > Peter Korsgaard <jacmet at sunsite.dk> wrote as thus:
> > > >>>>> "David" == David H Lynch <dhlii at dlasys.net> 
> > > David>     Have you tried 2.6.18.x to see if your stuff works with it
> > > David> ?
> > > 
> > > Yes, 2.6.18-rc3 + my zlib fix
> > > (http://thread.gmane.org/gmane.linux.kernel/428436) or -rc4 once it
> > > hits kernel.org works fine on my v2p-based board.
> > 
> > Well, unfortunately I am still getting the inflate error
> > as soon as the image grows >2MB (about). Have you tried with
> > images of this size? If the image is smaller, everything works
> > fine...
> My first reaction when I saw this thread was that you didn't allocate 
> something in memory and overlapped something.  However, looking
> at your original post again, I think your kernel is growing larger than
> 4MB, which is the link address of the zImage.  This is based on the 
> kernel is decompressed to address 0 in
> ppc/boot/simple/misc-embedded.c, and a 50% compression factor 
> and 2MB compressed image.
> You can look at the file size of vmlinux to see if this is close.
> milton

Well - That's exactly the case. But looking into misc-embedded.c, I noticed
that the load address for gunzip is fixed to 0x400000...shouldn't this

I've changed the line to

	gunzip(0, CONFIG_BOOT_LOAD, zimage_start, &zimage_size);
	gunzip(0, 0x400000, zimage_start, &zimage_size);

and now it seems to work fine for big images (if CONFIG_BOOT_LOAD 
is set large enough of course...) - which wasn't the case before.

Best regards
Benjamin Heyne

More information about the Linuxppc-embedded mailing list