XUPV2P, Kernel 2.6.17 boot problem

Milton Miller miltonm at bga.com
Sat Aug 12 14:37:25 EST 2006

On Mon Aug  7 2006 04:46:43 AM CDT, Benjamin Heyne wrote:
> Peter Korsgaard <jacmet at sunsite.dk> wrote as thus:
> > >>>>> "David" == David H Lynch <dhlii at dlasys.net> 
> > David>     Have you tried 2.6.18.x to see if your stuff works with it
> > David> ?
> > 
> > Yes, 2.6.18-rc3 + my zlib fix
> > (http://thread.gmane.org/gmane.linux.kernel/428436) or -rc4 once it
> > hits kernel.org works fine on my v2p-based board.
> Well, unfortunately I am still getting the inflate error
> as soon as the image grows >2MB (about). Have you tried with
> images of this size? If the image is smaller, everything works
> fine...

My first reaction when I saw this thread was that you didn't allocate 
something in memory and overlapped something.  However, looking
at your original post again, I think your kernel is growing larger than
4MB, which is the link address of the zImage.  This is based on the 
kernel is decompressed to address 0 in
ppc/boot/simple/misc-embedded.c, and a 50% compression factor 
and 2MB compressed image.

You can look at the file size of vmlinux to see if this is close.


More information about the Linuxppc-embedded mailing list