Trouble with 2.6.16 on ppc8xx ?

David Jander david.jander at
Fri Apr 14 18:50:56 EST 2006

Hi all,

I just cg-update'd to the HEAD of the denx 2.6.x kernel tree (2.6.16 as 
Our board-support stuff was succesfully moved along from 2.6.14 (when 
everything but the SCC3 and SCC4 uarts worked just fine).
I compiled a kernel without any special drivers, just console on ttyCPM0, but 
after "Uncompressing Kernel Image ... OK" there is no more output and no 
further activity on ethernet (it should boot from nfs-root) or any other 

After "cg-seek DENX-v2.6.15; make clean uImage", it works again (everything 
seems fine, system boots).

Our board is based on a MPC852T and until now we used "MPC86X" as the 
BOARD_CHIP_NAME and it worked just fine with 2.6.14 and 2.6.15, but not with 
2.6.16 as described above.

When doing "cg-diff" and carfully examining it's output, I can only see our 
board-support stuff (not very much, not very special) and some custom drivers 
that are disabled anyway.

Any clue about where to start looking?

I didn't find any suspicious changes in arch/ppc/mm, arch/ppc/syslib and 
arch/ppc/kernel. Neither in drivers/serial/cpm_uart.

Which change from 2.6.15 to 2.6.16 could have broken 8xx support for us?

Is there perhaps a known issue with 2.6.16 and ppc8xx I am unaware of?


David Jander

More information about the Linuxppc-embedded mailing list