lk2.4.25 compile fails with ELDK3.1

Sanjay Bajaj sbajaj at
Tue Jan 25 01:30:13 EST 2005

Hi! All,

I am new to this list, therefore, please correct my mistakes, if I do any.

I downloaded/installed ELDK 3.1 and also unzip lk2.4.25 which came with it. I used the default Xilinx ml300 config to compile the lk2.4.25. The following error is seen at the end of the compile:

ppc_4xx-objcopy -O elf32-powerpc \
        --add-section=.image=../images/vmlinux.gz \
        --set-section-flags=.image=contents,alloc,load,readonly,data \
        ../common/dummy.o image.o
ppc_4xx-ld -T ../ld.script -Ttext 0x00400000 -Bstatic -o zvmlinux head.o ../common/relocate.o  misc-embedded.o .
./common/misc-common.o ../common/string.o ../common/util.o ../common/serial_stub.o embed_config.o xiic_l.o ../co
mmon/ns16550.o image.o ../lib/zlib.a
ppc_4xx-objcopy -O elf32-powerpc zvmlinux zvmlinux -R .comment -R .stab -R .stabstr \
        -R .ramdisk -R .sysmap
mv zvmlinux ../images/zImage.
mv zvmlinux ../images/zImage.elf
mv: can't stat source zvmlinux
make[2]: *** [zImage] Error 1
make[2]: Leaving directory `/usr/src/linux-2.4.25/arch/ppc/boot/simple'
make[1]: *** [zImage] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.25/arch/ppc/boot'
make: *** [zImage] Error 2

I tried the same effort with ELDK 3.0 for lk2.4.24, that works fine. I have used different lk versions with ELDK 3.1 with the same result. Any ideas/pointers/explanations? They would greatly help.


More information about the Linuxppc-embedded mailing list