RFC: [PATCH] platform device driver model support

Kumar Gala kumar.gala at freescale.com
Thu Jan 13 15:19:39 EST 2005

> My $0.02.
> I didn't go thru in complete detail but I like the idea.  I have a
> couple minor comments, though.
> 1) Can we pick something other than 'soc' since the Marvell bridges
>  really aren't SOCs?  I don't really know what is better but just to
> throw something out, how about haing them all look like ppc_pd_xxx()?

What about ppc_plat_xxx() or ppc_sys_xxx() [for system]?  'sys' maybe 
more consistent with our naming conventions in that arch/ppc/platforms 
is more board focused, and arch/ppc/syslib is bridge and non-core chip 

> 2) In 8540_ads.c you're digging out platform_device entries and
> modifying them in your mpc8540ads_setup_arch() routine.  I think the
> platform_device "way" of doing that would be to make your mods via the
> platform_notify() hook (eventually called by device_add() which was
> ultimately called from platform_add_devices()).

This is problematic for some things like the updating of the IOMEM 
resources since that needs to occur before platform_device_register is 
called.  However, the updates in mpc8540_ads.c could possibly handled 
by platform_notify(), will look into that.

- kumar

More information about the Linuxppc-embedded mailing list