Problems with Serial Port on IceCube

Linas Petras lpetras at
Sat Feb 5 04:13:01 EST 2005

Hi All

I'm running Sylvain Munaut's version of 2.6.10-rc2 with DENX's 3.1 ELDK as
the cross
compile tools with nfs mounted root filesystem and I seem to have a probelm
when I'm 
connected to the "icecube" development boards serial port.

I get the u-boot 1.1.3 bootrom messages from the serial port on the
"icecube" and can 
boot the kernel using the serial port but I don't get any messages after the
boot message "arch: exit". It appeared to me that the board was booting so I
tried to 
telnet via the network to the board and this worked fine. So the kernel is
running, I 
just don't get the "normal" bootup messages from the kernel.

If I use the standard DENX 2.4.25 kernel I get all the message going to the
port OK.

Any ideas of whats going on ????? Is their a problem with the console
support in 
Sylvain's port or something in the "standard" init scripts that come with
3.1 when used with a 2.6.xx kernel or have I missed something obvious?

Linas Petras
I know not with which weapons World War III will be faught, but World War IV
will be faught with sticks and stones. - Albert Einstein.

More information about the Linuxppc-embedded mailing list