Linux on MPC5200 - LITE5200EVAL

Peter Falk peter.falk at
Wed Feb 11 20:53:59 EST 2004

Had the same problem with garbage, apparently a rounding problem in the
baudrate calculation.
The above patch shows the changes suggested by someone on the net, can't
remember his name but it is on the patches page of
After application of this it worked fine.
One gotcha, hardware handshake off on your terminal software! U-Boot
wants it off, The motorola DBUG wants it on, this kept me busy for a


Peter Falk

-----Original Message-----
From: owner-linuxppc-embedded at
[mailto:owner-linuxppc-embedded at] On Behalf Of Gerrit
Van de Velde
Sent: Wednesday, 11 February, 2004 10:19
To: Andrew Dennison
Cc: linuxppc-embedded at
Subject: RE: Linux on MPC5200 - LITE5200EVAL


> #dBUG commands to load u-boot via tftp
> set mac 00:01:AF:52:01:xx # see MPC5200LITE doco for how to choose xx
> value set client lite.ip.address set server tftpserver.ip.address
> set netmask your.netmask
> dn -i -o 0x100000 /tftpboot/u-boot.bin
> fe 0xff000000 0xff050000
> fp 0xff000000 0xff040000 0x100000
> #power off and change link to boot low
> #power up to u-boot

I followed these instructions and it all worked out fine (left out the
examples directory of U boot though) , but after the reboot in lowboot
jumper configuration, i only see garbage on my minicom screen. I can
figure out some characters that look familiar (like the countdown for
the autostart) so I assume it's working correctly but doesn't get
displayed right. I also can't interrupt the countdown so input doesn't
work. Already tried to change the 115200 8N1 settings of the
communications (but why would they change anyway..) and didn't help.

What could possibly be wrong ??

> read u-boot wiki to do it differently:)
> NOTE: if you have a Version 2.0 board and want 16MiB flash to actually
> you should ensure J24 is in the 2-3 position (J24 is a 0R resistor on
> bottom of the board).
> It is stupid for the jumper to be in the 1-3 position when 16MiB is
> but that is the way my board was. Seems like a manufacturing error:(

checked it and there's a resistor between 2-3 and not 1-3 so i guess
that's right.. (I have version 2.0 Lite)

> Andrew


-------------- next part --------------
A non-text attachment was scrubbed...
Name: serdiff.patch
Type: application/octet-stream
Size: 528 bytes
Desc: not available
Url : 

More information about the Linuxppc-embedded mailing list