Linux PCI support on Ocotea

Chris Love love at
Thu Dec 9 12:10:54 EST 2004

Hi folks,

We have an Ocotea reference board (PPC 440GX) w/256M and have
tried running both stable 2.4.26 and 2.6.10-rc3 kernels from  For now the bootloader is still PIBS, though
we'll get U-Boot installed shortly.

As a first experiment we've tried installing a legacy card
with an Intel 82559 device on it.  The warning seen from
pci_setup_device() suggests that PCI config space wasn't
read cleanly: a header type of 0x7f is encountered.  Nothing
shows up under /proc/bus/pci. The card we'd actually like to
install has a transparent bridge (Intel 21152) and other devices
behind the bridge.  Both cards are PCI-33 versus PCI-X.

To ask some really stupid questions first: what is the state of
PCI support with linux on this board?  Have others tried to do
something like this with 33/66 Mhz PCI devices or am I in
uncharted waters?

Of the PCI #defines in platforms/ocotea.h I can correlate most
with data from the user's manual, but not the following:

#define OCOTEA_PCI_LOWER_IO     0x00000000
#define OCOTEA_PCI_UPPER_IO     0x0000ffff
#define OCOTEA_PCI_LOWER_MEM    0x80000000
#define OCOTEA_PCI_UPPER_MEM    0xffffefff

Is there some documentation I'm missing on these values?

Thanks in advance for any suggestions,

Chris Love      // Continuous Computing Corporation
love at  //

More information about the Linuxppc-embedded mailing list