Network problem: Ping is OK, Yet telnet and ftp etc is not working

Ricardo Scop scop at
Thu Apr 1 04:45:18 EST 2004

On Wednesday 31 March 2004 00:02, Jack Liu wrote:
> hi,all
>      We use ADMTek AN983B chip as our network chip. And I have porting
> linux to this MPC8241 platform.Now I have a very strange problem:
>    If I ping my target, no answer. When I start tcpdump on my target,
> the ping ... works fine. Since the hardware is put into promiscuous
> mode when tcpdump is running, So I use ifconfig to put NIC work in
> promiscuous mode. I thought it can temporarily solve the problem. Now
> ping is OK. However When I telnet other machine, no answer.And When I
> telnet my target, still no answer. I thought it may because of firewall.
> So I undef CONFIG_NETFILTER in .config and autoconf.h. Still the same.
> So what could be the problem?

Well, check your interface's IP addressing for a wrong broadcast address; your
may also have a misconfiguration in your hardware's drivers,  related to the
the MAC address and/or broadcast address matching.


Ricardo Scop.
rscop at
+55 51 999-36-777
Porto Alegre, RS - BRazil

** Sent via the linuxppc-embedded mail list. See

More information about the Linuxppc-embedded mailing list