750/107 CHRP question

Richard Danter richard.danter at windriver.com
Fri Aug 1 18:16:21 EST 2003

Hi Wolfgang,

I am CC'ing the list as there may be some useful info in here...

Wolfgang Denk wrote:
> In message <3F298CED.8010701 at windriver.com> you wrote:
>>Yes, I work for WRS, but this is a little personal project just for the
>>hell of it. I just happen to be using a WRS board and vICE to do the
> Did you try what happens when you disconnect the visionIce?
> Are you 100% sure it understands virtual addresses correctly?

Yes, in fact besides my personal interest in Linux, my job is supporting
visionXXX customers (I worked for EST before it was bought by WR).

There is a command in the vICE-II called "CF MMU LINUX" which turns on
MMU handling (doesn't have to be Linux running) and then you use the
MMUA command to set up the mapping (eg MMUA C0000000 0 F0000000) and hey

I have been stepping through the kernel source code quite happily. I
tracked the problem down the the point where the 1st write occurs to the
serial port. If I let it run on from there I end up in an inf. loop
which just jumps to itself. When I reach that point I can stop the
target and use the memory window to dump the "log_buf" which is where
all the kprintf messages are going and I can get the back trace from
that and it points to the same offending instruction in serial setup.

I also tried not having a serial port compiled in and everything works

It is fixed now tho as I decided to add a ioremap() call. The other
suggestions I got ware probably more flexible but this was so simple -
just editing 1 line.


** Sent via the linuxppc-embedded mail list. See http://lists.linuxppc.org/

More information about the Linuxppc-embedded mailing list