BDI2000 breakpoints in dynamically loaded modules

Rudolf Ladyzhenskii rudolf.ladyzhenskii at
Wed Jan 23 12:13:06 EST 2002

Hi, all

I am using BDI2000 to debug dynamically loaded module under Linux. When I
put a breakpoint, it never goes off, but code does execute.

At the moment the only 8260 board we have is used 100% of the time, so I do
not have much chance to do any investigation.
I'll describe what I do, may be this will help.

I load the moule under Linux and then use "add-symbol-file" command. This
allows me to view the source of my module. Then I put a breakpoint either
through IDE (DDD) or from GDB prompt. Breakpoint appears in DDD, but never
goes off. All memory translation is working.

I can not remember if it worked before, I only briefly tried modules while
ago. I recently upgraded DDD and BDI2000 firmware to the latest versions.
May be this caused it?

Any ideas are appreciated.,



** Sent via the linuxppc-embedded mail list. See

More information about the Linuxppc-embedded mailing list