kernel thread

Meena Ramamoorthi meena at
Thu Jan 25 11:53:44 EST 2001

 Hi Frank,

 I tried this program. When i do insmod hello.o or hello_module.o  it says
unresolved symbol kernel_thread. So the problem is still not resolved.


-----Original Message-----
From: owner-linuxppc-embedded at
[mailto:owner-linuxppc-embedded at]On Behalf Of Frank
Sent: Wednesday, January 24, 2001 2:00 PM
To: Meena Ramamoorthi
Cc: linuxppc-embedded at; frowand at
Subject: Re: kernel thread

Meena Ramamoorthi wrote:
>   Hi all,
>  Has anybody tried using kernel_thread under montavista - IBM 405GP PPC
> hardhat LINUX kernel. ( 2.4 )  If so could you please reply to this. We
> problem in exporting this. kernel_thread unresolved.
>   Early answer appreciated
>  Thanks and best regards,
>  Meenakshi

The symbol is there.  I'll attach a trivial module that accesses the symbol

Frank Rowand <frank_rowand at>
MontaVista Software, Inc

** Sent via the linuxppc-embedded mail list. See

More information about the Linuxppc-embedded mailing list