Cross-compiling Bash

Rob Grimm rgrimm at
Sat Mar 11 09:11:09 EST 2000

    I apologize if this topic has come up before, I checked the archives but
not find the answer I'm looking for.

     I have successfully setup a cross-compiler
on an x86 computer, to build code for our embedded PowerPC750 platform.  I
have been able compile the kernel, create a ramdisk, and the kernel boots
I have been using a small filesystem I downloaded for the mbx board, and can
run the included bash.   My question is, has anyone successfully
bash (any version, or any GNU software package for that matter)?  Whenever
I run configure (I set all the command line options, like
CC=mycompilername --target=
blah), it says something like can not run test when using cross - compiling.
I get the same results, no matter which GNU package I try to compile (ie
I have also tried running configure with no options, and then manually
the makefiles so it uses my cross-compiler, this does not work either.
Here is the stuff I am using for my cross-compiler (which has all been built

Does anyone have any suggestions?  I'm trying to avoid going out and buying
a powermac.  How do others handle this problem, when developing code
on a non-powerpc platform?

    Also, I have tried running pre-built binaries, which I got from
ftp.linuxppc.orq, with
no success.  I downloaded pre-built libs, bash..., and all I get is "init"
on the console
after the kernel boots.  It then hangs up.

Thanks in advance.

Rob Grimm

Rob Grimm
Real-Time Digital
rgrimm at

** Sent via the linuxppc-embedded mail list. See

More information about the Linuxppc-embedded mailing list