glibc for mpc860

Brendan Simon bsimon at
Fri Sep 10 16:37:54 EST 1999

Dan Malek wrote:

> Brendan Simon wrote:
> > ... I dowloaded the latest glibc (2.1.1) from a GNU mirror
> > and it compiled fine with my egcs-1.1.2 powerpc-linux cross-compiler.  I
> > tried adding the -mcpu=860 option and it barfed.
> I still use the old libc-1.99 stuff.  I have not looked into
> using the newer glibc2.  I don't use cross compilers because of
> problems others have had.  That could be some of the problem
> as well.

I just downloaded the tar.gz archive from the LinuxPPC ftp site.  It has the libaries but not the source.  I thought at least
the headers would be in there but it doesn't look like it.
Excuse my ignorance but is the libc-1.99 stuff a GNU product ?

I assume by the statement "I don't use cross compilers" means that you use the native compiler on a LinuxPPC machine (powermac
or something).  This would mean that the instructions generated are for 601, 603 or whatever the default is.  This would surely
cause problems on an MPC860 processor wouln't it ?

> > ..... I assume that the glibc
> > developers do not consider targets without a floating point processor as
> > a non-priority (I wish the MPC860 had an FPU).
> It seems anything that is not the latest and fastest silicon is
> a non-priority :-).  I had the patches for the libraries in the
> one was interested.  If you really need an FPU, you
> should probably be using something other than an 8xx.  I have done
> lots of cool 8xx applications, mostly communications related.
> I have never needed an FPU.

I don't have a NEED for an FPU for most projects but I still wish it was available.  There aren't too many CPUs these days that
don't have one built in (except for 8, 16 and some embedded 32 bit processors).  A lot of software these days assumes that an
FPU is present (eg. glibc by the looks of it).  It would be nice to have an FPU just incase it was useful.  I'm sure it wouldn't
cost Motorola much to put it on.  It's just a wish.  Sigh...  I thought the MPC8260 would have an FPU but it appears not.  Ah

> > ......It looks like others
> > have ported/modified some glibc sources to work with the -mcpu=860
> > option.
> You shouldn't have to modify anything in the sources to get it
> to compile.  The hardest part is getting the flags in the Makefiles.

I think I used something like "CC=powerpc-linux CFLAGS=-mcpu=860 configure" when I tried compiling glibc.  The -mcpu=860 flag
was present in the commands generated by Make which caused the glibc build to die.  Maybe there is something like -msoft or -nfp
that I can try ?

> I attached the single file to be modified for the cache line stuff
> in the older glibc-1.99 sources.  You can also remove the floating
> point instructions in the set/long jump function, but it is not
> necessary.  Those are the only floating point instructions in
> the libraries.

I'll have a look.

Brendan Simon.

** Sent via the linuxppc-embedded mail list. See

More information about the Linuxppc-embedded mailing list