[PATCH -next] [POWERPC] Rename get_property to of_get_property: use DEFINE_SPINLOCK() for spinlock

weiyongjun (A) weiyongjun1 at huawei.com
Fri Apr 9 19:47:29 AEST 2021


Rename get_property to of_get_property: use DEFINE_SPINLOCK() for spinlock

~~~~~~~~~~~~~

这是啥模块名?


在 2021/4/9 17:51, Ye Bin 写道:
> spinlock can be initialized automatically with DEFINE_SPINLOCK()
> rather than explicitly calling spin_lock_init().
>
> Reported-by: Hulk Robot <hulkci at huawei.com>
> Signed-off-by: Ye Bin <yebin10 at huawei.com>
> ---
>   drivers/macintosh/via-pmu-led.c | 4 +---
>   1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/drivers/macintosh/via-pmu-led.c b/drivers/macintosh/via-pmu-led.c
> index ae067ab2373d..2502119cff42 100644
> --- a/drivers/macintosh/via-pmu-led.c
> +++ b/drivers/macintosh/via-pmu-led.c
> @@ -27,7 +27,7 @@
>   #include <linux/pmu.h>
>   #include <asm/prom.h>
>   
> -static spinlock_t pmu_blink_lock;
> +static DEFINE_SPINLOCK(pmu_blink_lock);
>   static struct adb_request pmu_blink_req;
>   /* -1: no change, 0: request off, 1: request on */
>   static int requested_change;
> @@ -105,8 +105,6 @@ static int __init via_pmu_led_init(void)
>   		return -ENODEV;
>   	}
>   	of_node_put(dt);
> -
> -	spin_lock_init(&pmu_blink_lock);
>   	/* no outstanding req */
>   	pmu_blink_req.complete = 1;
>   	pmu_blink_req.done = pmu_req_done;
>


More information about the Linuxppc-dev mailing list