[PATCH v2 1/3] init/main.c: Give init_task a canary
Aaron Tomlin
atomlin at redhat.com
Wed Sep 10 23:29:33 EST 2014
On Wed, Sep 10, 2014 at 02:26:54AM -0500, Chuck Ebbert wrote:
> On Tue, 9 Sep 2014 10:42:27 +0100
> Aaron Tomlin <atomlin at redhat.com> wrote:
>
> > +void task_stack_end_magic(struct task_struct *tsk)
> > +{
> > + unsigned long *stackend;
> > +
> > + stackend = end_of_stack(tsk);
> > + *stackend = STACK_END_MAGIC; /* for overflow detection */
> > +}
> > +
>
> For clarity this should probably be called set_task_stack_end_magic().
Agreed.
> And has this been tested on parisc and metag, which use STACK_GROWSUP ?
> I can't see how end_of_stack() as it's defined now could work on those archs.
AFAIU, dup_task_struct() has always done this explicitly.
I see no reason why init_task requires special attention.
--
Aaron Tomlin
More information about the Linuxppc-dev
mailing list