[PATCH v2 1/3] init/main.c: Give init_task a canary
Chuck Ebbert
cebbert.lkml at gmail.com
Wed Sep 10 17:26:54 EST 2014
On Tue, 9 Sep 2014 10:42:27 +0100
Aaron Tomlin <atomlin at redhat.com> wrote:
> +void task_stack_end_magic(struct task_struct *tsk)
> +{
> + unsigned long *stackend;
> +
> + stackend = end_of_stack(tsk);
> + *stackend = STACK_END_MAGIC; /* for overflow detection */
> +}
> +
For clarity this should probably be called set_task_stack_end_magic().
And has this been tested on parisc and metag, which use STACK_GROWSUP ?
I can't see how end_of_stack() as it's defined now could work on those archs.
More information about the Linuxppc-dev
mailing list