[RFC Patch] 405gp IBM EMAC Phy probe fails with no link

Andrew May acmay at acmay.org
Tue Oct 9 17:23:35 EST 2012

I have an older PPC 405GP board with a 2.6.33 kernel that fails to 
install a eth0 instance because the phy probe fails when there is no 
good ethernet link.
I have looked at the latest kernel code and it seems just about the same 
in this area, but I have not tried it.

Does anyone else still have a 405GP board to try and see if eth0 comes 
up with not enet cable?

I tried to probe the phy earlier and skip the emac_configure() call in 
emac_init_phy() to avoid doing the MR0_SRST bit set.
But the phy read still times out.

I then went with this approach to re-call emac_init_phy() after the 
emac_reset() finally completes when a cable is plugged in.
Does anyone else have any ideas why the phy probe fails on the first pass?
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ibm_phyprobe.patch
Type: text/x-patch
Size: 2450 bytes
Desc: not available
URL: <http://lists.ozlabs.org/pipermail/linuxppc-dev/attachments/20121008/55ee187e/attachment.bin>

More information about the Linuxppc-dev mailing list