Timer interrupt on Linux 3.0.3

MohanReddy koppula mohanreddykv at gmail.com
Thu Sep 22 16:22:34 EST 2011

I had the same issue with an MPC885 board. My kernel was 2.6.33. On
that board decrementer exception was not working. I replaced the
board, took new board (MPC885 only, just another board) and the same
kernel worked fine. I don't know how the problem was solved.


On 9/22/11, Scott Wood <scottwood at freescale.com> wrote:
> On 09/21/2011 01:56 AM, Vineeth wrote:
>>>> What was the issue?  You really should try to make this work rather than
>>>> hack around it.
>> what we found was the decrementer is not generating an exception when it
>> becomes 0. and the timebase registers are not getting incremented too.
> Does the decrementer actually tick until it reaches zero, or do it and
> the timebase never tick?
> Is the TBEN input to the CPU asserted?
> -Scott
> _______________________________________________
> Linuxppc-dev mailing list
> Linuxppc-dev at lists.ozlabs.org
> https://lists.ozlabs.org/listinfo/linuxppc-dev

More information about the Linuxppc-dev mailing list