[PATCH 1/2] powerpc: pci config cleanup

Michael Ellerman michael at ellerman.id.au
Thu Jun 26 10:53:54 EST 2008


On Wed, 2008-06-25 at 14:19 -0600, John Rigby wrote:
> change
>     bool "PCI support" if <long ugly expression>
> to
>     bool "PCI support" if PPC_HAS_PCI
> 
> and add select PPC_HAS_PCI to all the config nodes that
> were previously in the PCI if expression
> 
> diff --git a/arch/powerpc/Kconfig b/arch/powerpc/Kconfig
> index 3934e26..fa9bd91 100644
> --- a/arch/powerpc/Kconfig
> +++ b/arch/powerpc/Kconfig
> @@ -542,11 +542,12 @@ config FSL_LBC
>  config MCA
>  	bool
>  
> +config PPC_HAS_PCI
> +	bool
> +
>  config PCI
> -	bool "PCI support" if 40x || CPM2 || PPC_83xx || PPC_85xx || PPC_86xx \
> -		|| PPC_MPC52xx || (EMBEDDED && (PPC_PSERIES || PPC_ISERIES)) \
> -		|| PPC_PS3 || 44x
> -	default y if !40x && !CPM2 && !8xx && !PPC_MPC512x && !PPC_83xx \
> +	bool "PCI support" if PPC_HAS_PCI
> +	default y if !40x && !CPM2 && !8xx && !PPC_83xx \
>  		&& !PPC_85xx && !PPC_86xx
>  	default PCI_PERMEDIA if !4xx && !CPM2 && !8xx
>  	default PCI_QSPAN if !4xx && !CPM2 && 8xx

This is backward I think. The bool says whether you get to choose if you
have PCI, not if you have it. It should be called CAN_CHOOSE_PCI or
something.

For example this makes no sense:

> diff --git a/arch/powerpc/platforms/pseries/Kconfig b/arch/powerpc/platforms/pseries/Kconfig
> index 07fe5b6..e205066 100644
> --- a/arch/powerpc/platforms/pseries/Kconfig
> +++ b/arch/powerpc/platforms/pseries/Kconfig
> @@ -7,6 +7,7 @@ config PPC_PSERIES
>  	select RTAS_ERROR_LOGGING
>  	select PPC_UDBG_16550
>  	select PPC_NATIVE
> +	select PPC_HAS_PCI if EMBEDDED


cheers

-- 
Michael Ellerman
OzLabs, IBM Australia Development Lab

wwweb: http://michael.ellerman.id.au
phone: +61 2 6212 1183 (tie line 70 21183)

We do not inherit the earth from our ancestors,
we borrow it from our children. - S.M.A.R.T Person
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <http://lists.ozlabs.org/pipermail/linuxppc-dev/attachments/20080626/e92f5cb6/attachment.pgp>


More information about the Linuxppc-dev mailing list