2.6.23-rc3 boot hang on MPC8641D

sivaji rameshmrm at gmail.com
Thu Sep 13 14:47:28 EST 2007

          I have JTAG Debugger connected to the board. I was given the
following commands in the root path of the kernel source

1. ${CROSS_COMPILE}gdb vmlinux
2. I got th GDB prompt  after that i give
          target remote i got following results
         (gdb) target remote
Remote debugging using
Remote packet too long:
Ignoring packet error, continuing...
0xdeadbeef in ?? ()
3.(gdb) b start_kernel
Cannot access memory at address 0xc02b44ec


Kumar Gala-3 wrote:
> On Sep 12, 2007, at 11:18 PM, sivaji wrote:
>> Hi,
>>         I am try to boot the 2.6.23-rc3 kernel to my custom board  
>> based on
>> 8641D Processor. After uncompressing the kernel it was hang. I got the
>> following messages.
>>    Uncompressing Kernel Image ... OK
>>    Booting using flat device tree at 0x600000.
>>        Then i tried to debug with GDB. In my source path i given  
>> the command
>> ${CROSS_COMPILE}gdb vmlinux, I got GDB Prompt after i tried to set the
>> breakpoint at start_kernel. I got follwing messages
>> gdb) b start_kernel
>> Cannot access memory at address 0xc02b44ec
> how are you connecting gdb to the board?
> do you have a JTAG debugger connected to the board?
> - k
> _______________________________________________
> Linuxppc-dev mailing list
> Linuxppc-dev at ozlabs.org
> https://ozlabs.org/mailman/listinfo/linuxppc-dev

View this message in context: http://www.nabble.com/2.6.23-rc3-boot-hang-on-MPC8641D-tf4433508.html#a12648671
Sent from the linuxppc-dev mailing list archive at Nabble.com.

More information about the Linuxppc-dev mailing list