[PATCH] Stop pmac_zilog from abusing 8250's device numbers.
dwmw2 at infradead.org
Wed Apr 4 08:58:39 EST 2007
On Tue, 2007-04-03 at 13:37 -0700, Brad Boyer wrote:
> Shouldn't we have defines for these? It doesn't seem good to have more
> magic numbers floating around in the code.
I wondered about that, but decided against it. They're only used in one
place, and it's obvious what they are and where they come from. It's not
as if '#define PMAC_ZILOG_MAJOR 204' and '.major = PMAC_ZILOG_MAJOR'
would actually make it any clearer. Quite the opposite, in fact, since
204 is used for other things too.
More information about the Linuxppc-dev