[PATCH] Stop pmac_zilog from abusing 8250's device numbers.
Brad Boyer
flar at allandria.com
Wed Apr 4 06:37:36 EST 2007
On Tue, Apr 03, 2007 at 10:25:45AM -0400, David Woodhouse wrote:
> There are proper device numbers registered for pmac_zilog now. Use them.
>
> Signed-off-by: David Woodhouse <dwmw2 at infradead.org>
>
> diff --git a/drivers/serial/pmac_zilog.c b/drivers/serial/pmac_zilog.c
> index 752ef07..579266d 100644
> --- a/drivers/serial/pmac_zilog.c
> +++ b/drivers/serial/pmac_zilog.c
> @@ -99,9 +99,10 @@ static DEFINE_MUTEX(pmz_irq_mutex);
>
> static struct uart_driver pmz_uart_reg = {
> .owner = THIS_MODULE,
> - .driver_name = "ttyS",
> - .dev_name = "ttyS",
> - .major = TTY_MAJOR,
> + .driver_name = "ttyPZ",
> + .dev_name = "ttyPZ",
> + .major = 204,
> + .minor = 192,
> };
>
>
> @@ -1800,7 +1801,6 @@ static int __init pmz_register(void)
>
> pmz_uart_reg.nr = pmz_ports_count;
> pmz_uart_reg.cons = PMACZILOG_CONSOLE;
> - pmz_uart_reg.minor = 64;
>
> /*
> * Register this driver with the serial core
>
Shouldn't we have defines for these? It doesn't seem good to have more
magic numbers floating around in the code.
Brad Boyer
flar at allandria.com
More information about the Linuxppc-dev
mailing list