Realtime preemption patch on PPC

Ben Weintraub benwei at
Fri Aug 11 10:55:35 EST 2006

(Sorry for those of you who see this message twice, it was originally  
posted in the linuxppc-embedded list, but Mark Greer suggested  
posting it here too)


I'm wondering if anyone has had success getting Ingo Molnar's realtime
preemption patch (the one here: ) working on the ppc

I'm working with patch-2.6.17-rt8 (the latest) and linux-2.6.17.  The
realtime-preempt patch seems to include the generic timeofday patch, but
with no support for the ppc arch, only powerpc, so I've hacked in
support for ppc by basically replicating the powerpc arch-specific stuff
found here: 

I can attach my patch if anyone would like, but for all I know it could
be wildly inaccurate.

Anyhow, when I boot on an MPC8555 with my hack, I get an endless stream

BUG: sleeping function called from invalid context init(1) at
in_atomic():0 [00000000], irqs_disabled():1
Call Trace:
[A0BB3E90] [A000934C] show_stack+0x48/0x194 (unreliable)
[A0BB3EC0] [A001B7DC] __might_sleep+0xe8/0xf4
[A0BB3EE0] [A00136C0] do_mathemu+0x30/0x8c8
[A0BB3F00] [A00036AC] program_check_exception+0x1ac/0x514
[A0BB3F40] [A0002A08] ret_from_except_full+0x0/0x4c

Line 226 in arch/powerpc/math-emu/math.c is part of the do_mathemu()
function, and contains a call to get_user(), which calls
__might_sleep(), causing this problem.

I did find this message in the LKML archives describing a very similar

And so tried putting a call to local_irq_enable() before the call to
do_mathemu() in program_check_excpetion(), but this causes a hard lockup
with no messages printed when I try to bring up my network interface.  I
assume this means I've done something Very Bad with interrupts by adding
in local_irq_enable() at the wrong spot.  I also tried adding it at the
exact same spot as the patch given by Paul in his reply, but in this
case I still get the endless stream of BUG messages.

Can anyone offer some guidance or advice?

Thanks so much,

More information about the Linuxppc-dev mailing list