Problem with SCC uart in UART mode on mpc8270 w/ Linux-

Vipin.Malik at Vipin.Malik at
Fri Aug 11 10:55:34 EST 2006


I'm trying to use the SCC1 in uart mode on a MPC8270 under from

I've turned on all SCC uarts and I can send and rx data but have an
The first time I open the port (ttyCPM2) by "cat /dev/ttyCPM2" and "cat
I can tx and rx fine.

The problem occurs when I close the first cat session and open it again.

This time, my TX has some sort of threshold in it. It seems that only
after a few 10's of bytes have been sent to the port (the fifo size?
Need to
check) does the scc actually send the data. After that it's all ok.

However, my rx never works after the 1st port open.

Console is on SMC1 and works fine all the time.

I'm using non-platform mode (whatever I tried to do in platform mode, my
SMC1 console stopped working/board stopped working. I would not get any
output after u-boot starts the kernel- not even the Linux version

Any ideas?


P.S. I had to hack the compat code to get the BRG's wired properly for
the SCC's, but the SCC works the 1st time and tx works (besides the
 issue)- so I don't think that is the cause.

I also tried to get platform code working, but not luck. Is there any
 document or email anywhere I can read that explains that setup?

More information about the Linuxppc-dev mailing list