mv643xx_eth SA_SHIRQ support patch
benh at kernel.crashing.org
Wed Mar 9 18:39:27 EST 2005
On Wed, 2005-03-09 at 08:17 +0100, Sven Luther wrote:
> vendor-id 0x11AB (4523)
> device-id 0x6460 (25696)
> revision-id 0x3 (3)
> class-code 0x60000 (393216)
> subsystem-id 0x0 (0)
> subsystem-vendor-id 0x0 (0)
> .vendor-name "Marvell"
> .part-number "MV6436x"
> .description "System Controller for PowerPC Processors"
> .class "Bridge Device"
> .subclass "Host/PCI"
> devsel-speed 0x0 (0)
> min-grant 0x0 (0)
> max-latency 0x0 (0)
> name "host"
> reg 0:0
Ok, teach them the interest in having a "model" and "compatible"
property in them for their next version...
> In the /pci/host node, i also have :
> model "Pegasos2"
> In the root node, and in the new OF, we even have a /discovery2/port at 1 or
> something such, but it is unreleased yet.
Ugh ? What is that supposed to be ?
If it's an ethernet port, it should be called "ethernet".
> The thing is not that there is no info, just to chose which info is best.
> Christoph suggested to not do that though, but use the normal pci stuff and
> match on the host pci id with pci_dev_present. This is what i was thinking of
> doing too, and may be more logical, no ?
Yah, if there is no meaningful OF name, then probably.
More information about the Linuxppc-dev