[FYI] linux 2.6 still not working with PReP (ppc32)

Sebastian Heutling sheutlin at gmx.de
Mon Jan 10 10:17:54 EST 2005

Marc Dietrich wrote:

>Hi all,
>I didn't recognise that the kernel from Sebastian - which was working fine 
>here - was build from the debian sources (no hint in the kernel version). 
>So I build everything again from debian source and fixed the irq's in 
Erm ... well ... yes - it's a debian kernel ;).

>I can confirm now, that this debian+irq_fix kernel 2.6.8 runs fine and 
>produces no scsi timeouts!
>Something happend in kernels >= 2.6.9 which makes the scsi unusable. Also it 
>seems, that even in 2.6.8 kernels and with ide hard disks (Sebastians setup) 
>the scsi controller timeouts, but continues to operate - correct?

Yep correct.
I also tried the 2.6.10 and found out that it doesn't work here as well. 
First I get a lot of lost interrupts from the IDE driver and after that 
I also get the SCSI timeouts. It must have something to do with the prep 
changes in 2.6.9. One difference in IRQ setup I noticed is in 
prep_pcibios_fixup(). If I remember correctly before 2.6.9 at least on 
this Utah machine the IRQs are assigned from Motherboard_routes[] 
without doing anything else. Now additionally the IRQ is also written 
into the devices pci config space which might not work on the 
PowerstackII Utah.
It's only a guess and I haven't had the time yet to test it.


More information about the Linuxppc-dev mailing list