[FYI] linux 2.6 still not working with PReP (ppc32)

Christian evilninja at gmx.net
Mon Dec 27 13:47:05 EST 2004

Marc Dietrich schrieb:
> Hi all,
> I read this thread about booting a PowerStack with newer kernels. Motivated by 
> this, I tried to compile a 2.6.10 kernel on my machine (with sym53c825a 
> onboard). Sadly, the scsi controller always timeouts during initialisation. I 

yes, booting is fine now, but i don't have a scsi disk (well, i only 
need the right cable...) in the PReP and booting diskless atm.

> had this problem also with the 2.4er kernels, but this was solved in later 
> versions (I'm running 2.4.21 now). Now the old driver seem to be removed (or 
> merged with sym53c8xx_2) and is only available to MCA and GSC devices.

yes, i had scsi timeout issues too with 2.4 and early 2.5 kernels. i've 
never tried newer 2.4 kernels with scsi-disk inside and i am happy to 
hear that the issues have been resolved.

> I also tried to change the irq routings in prep_pci.c like in the latest patch 
> with the sym53c8xx_2 driver,
> 	Slot 12 -> IRQ 15 (sym53c825)
> 	Slot 15 -> IRQ 11 (dec 21140)
> but this didn't helped.

i'm still working these out too, gotta find some time...

> Has anyone a working config file for this machine (PowerStack II 4000/Utah)?

i've found and attached a file called "config-2.6-minimal" from 
19-12-2003, linux 2.6.0 was released 17-Dec-2003. in there scsi is 
enabled, but i doubt i was able to boot this, because of the network 
issues. however, i only did "yes '' | make oldconfig" from 2.5.30 on, so 
the scsi part of this .config shouldn't have changed much.

BOFH excuse #387:

Your computer's union contract is set to expire at midnight.
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: config-2.6-minimal
URL: <http://lists.ozlabs.org/pipermail/linuxppc-dev/attachments/20041227/e3144127/attachment.txt>

More information about the Linuxppc-dev mailing list