[FYI] linux 2.6 still not^Wnow working with PReP (ppc32)

Christian Kujau evil at g-house.de
Mon Dec 6 15:15:19 EST 2004

Hash: SHA1

Sebastian Heutling schrieb:
> Pure trial and error in the first time. When realising that something is
> wrong with the assigned interrupts (looking at the kernel output) we
> tried to set the ones that were working in a 2.4 kernel. When the
> machine finally booted a "lspci" showed that the slot number changed.

lspci, sounds easy ;-)
but i never would have looked at slot numbering....

> Is it that onboard network tulip kind of thingy? Do you have some other
> PCI cards installed?

the card is onboard. since i had some issues with this card in early 2.4
kernels too, i used to have another NIC. in fact, very often i only
compiled with 3c59x enabled - OF cared about the onboard NIC (tulip) and
once the kernel is loaded, the tulip is not needed any more and 3c59x
takes over.

http://nerdbynature.de/bits/sheep/2.6.10-rc3/  has some details.

> I used to have an extra symbios logic scsi-host-adapter installed.
> On high network load and loading/writing to a HD (using onboard scsi), I
> noticed a lot of problems: either the scsi-host-adapter lost the
> interrupt or the network driver lost some packets or both. After having
> removed the extra scsi-host-adapter it works fine now.

hm, when i had 3 scsi-disks in this machine (fine IBM ones, hmmmm..) i
only used the on-board scsi-bus. there was no other scsi-host-adapter
inside, but i noticed the very same problems: upon massive i/o, the
machine got stuck for 30sec, sometimes longer, load increased to 30..40 or
so, then the machine got back, with a syslog full of scsi errors.

it's still so incredible that a 3-liner solved this issue. the bug-report
was opened over a year ago...

thanks again,
- --
BOFH excuse #13:

we're waiting for [the phone company] to fix that line
Version: GnuPG v1.2.5 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org


More information about the Linuxppc-dev mailing list