[FYI] linux 2.6 still not working with PReP (ppc32)

Sebastian Heutling sheutlin at gmx.de
Mon Dec 6 12:46:14 EST 2004

On Sun, 2004-12-05 at 18:41 +0100, Christian Kujau wrote:
> Hash: SHA1
> Sebastian Heutling schrieb:
> > You got the powerstack booting from scsi (reading and interpreting the
> yes, but now the disk is gone and i have to use nfsroot.
> > bug report). I had problems booting 2.6 kernels as well (never tested
> > any 2.5 kernels). It turned out that the pci slot numbering has changed
> > sometime and this wasn't reflected in arch/ppc/platforms/prep_pci.c.
> > After having set up the slot0...slot8 using the values of
> > slot10...slot18 (except for slot1 which got value 4 so IDE is usable out
> > of the box), the machine booted a 2.6 kernel (2.6.8).
> boy! this *is* an early christmas present, for sure! how did you come to
> this conclusion? something *must* have changed in the pci setup after


Pure trial and error in the first time. When realising that something is
wrong with the assigned interrupts (looking at the kernel output) we
tried to set the ones that were working in a 2.4 kernel. When the
machine finally booted a "lspci" showed that the slot number changed.

> 2.5.30, because the problem did not go away when i used a different NIC
> driver. but i could not fiddle out the changeset to blame here, because i
> failed to compile many kernels > 2.5.30.
> changing one line in arch/ppc/platforms/prep_pci.c made my PReP booting a
> recent 2.6-BK, patch attached.
> it's booting now, "init=/bin/bash" is working, but i still can't ping to
> the outside world, which is still a bit strange, but i hope i can work it out.

Is it that onboard network tulip kind of thingy? Do you have some other
PCI cards installed?
I used to have an extra symbios logic scsi-host-adapter installed.
On high network load and loading/writing to a HD (using onboard scsi), I
noticed a lot of problems: either the scsi-host-adapter lost the
interrupt or the network driver lost some packets or both. After having
removed the extra scsi-host-adapter it works fine now.

> tausend dank (really),

You are welcome!


More information about the Linuxppc-dev mailing list