ADS8260 Hang

Wolfgang Denk wd at
Fri Apr 23 05:42:00 EST 2004

In message <001101c42832$ec117760$3401080a at> you wrote:
> I initially tried using Linux 2.4.1 kernel and it worked fine and the
> board was up.
> I upgraded to 2.4.17 and I found out that the system started hanging
> during boot up.

I guess you didn't read the FAQ; see

I think you must unset the "clocks_in_mhz" environment variable.

> I tried tracking down where the hang could be and ended up at the RFI
> instruction where its waiting to complete the MMU initialization. The
> system executes SYNC instruction and then hangs. (arch/ppc/kernel/head.S)

I think you are hunting a ghost; and again you didn't read the FAQ; see

Best regards,

Wolfgang Denk

Software Engineering:  Embedded and Realtime Systems,  Embedded Linux
Phone: (+49)-8142-4596-87  Fax: (+49)-8142-4596-88  Email: wd at
"When the only  tool  you  have  is  a  hammer,  you  tend  to  treat
everything as if it were a nail."                    - Abraham Maslow

** Sent via the linuxppc-dev mail list. See

More information about the Linuxppc-dev mailing list