ADS8260 Hang

challaharikumar challaharikumar at
Thu Apr 22 16:27:44 EST 2004

Hi All,

I having been trying to bring up the ADS8260 board and incidentally ran
into some problems.

I initially tried using Linux 2.4.1 kernel and it worked fine and the
board was up.
I upgraded to 2.4.17 and I found out that the system started hanging
during boot up.

I compiled 2.4.17 for ppc boot. (I already have ppc boot on my ADS board
and I test my development by tftp boot'ing the kernel image.

I tried tracking down where the hang could be and ended up at the RFI
instruction where its waiting to complete the MMU initialization. The
system executes SYNC instruction and then hangs. (arch/ppc/kernel/head.S)

I tried comparing the file head.S between 2.4.1 and 2.4.17. I found out
some patches done inside the 2.4.1 had been made generic. There were
patches for the BAT initialization and RAM mapping on the MPC8260.

Is there an update on the files?
Should the patches be done for 2.4.17 as well ?

Any suggestions or pointers could be very helpful.

[Running on x86 with Red Hat 8.0 and cross compiling for PPC.]

** Sent via the linuxppc-dev mail list. See

More information about the Linuxppc-dev mailing list