Kernel Module; globals badly initialized, help needed.

Paul Mackerras paulus at
Thu Mar 28 11:49:37 EST 2002

Goddeeris Frederic writes:

> I am having lots of problems with global variables that are badly
> initialized in a kernel
> module. I wrote some very simple code showing the problem. The compiler I
> use is gcc 2.95.3

Hmmm.  I just tried your test module and it worked fine.  It produced
the following output:

TestDriver 3 Loaded
MyMemSpace: 0xd18b92a0 0xd18b93a0
MemPointers: 0xd18b92a0 0xd18b93a0
First Char is MyStruct[0].szName A

which looks fine to me.  This was with a 2.4.18 kernel.

The command line I used to compile it was:

bash-2.05a$ gcc -D__KERNEL__ -I/home/paulus/kernel/pmac-2.4.18/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common -I/home/paulus/kernel/pmac-2.4.18/arch/ppc -fsigned-char -msoft-float -pipe -ffixed-r2 -Wno-uninitialized -mmultiple -mstring -DMODULE  -DKBUILD_BASENAME=modtest -c modtest.c

I got this by doing `make modules' in a kernel tree and taking the
command that it used for the first module it came across (which
happened to be serial.c) and substituting modtest for serial.

I did some minor cleanups to the code, the actual code I used is


#include <linux/module.h>
#include <linux/kernel.h>
#include <linux/init.h>

char MyMemSpace[2*0x100];
char *MemPointers[2] = {&(MyMemSpace[0]), &(MyMemSpace[0x100])};

typedef struct
	char *szName;
	char *szName2;
} MyStruct_t;

MyStruct_t MyStruct[] = {{"A", "A2"}, {"B", "B2"}};

int init_module(void)
	printk("TestDriver 3 Loaded\n");

	printk("MyMemSpace: 0x%lx 0x%lx \n",  (long)&(MyMemSpace[0]),
	printk("MemPointers: 0x%lx 0x%lx \n", (long)(MemPointers[0]),

	printk("First Char is MyStruct[0].szName %c\n",

	return -1;

void cleanup_module(void)


** Sent via the linuxppc-dev mail list. See

More information about the Linuxppc-dev mailing list