[Question] I want to use CSCOPE to port Linux kernel.

Jerry Van Baren vanbaren_gerald at si.com
Fri Sep 21 01:27:10 EST 2001

You may also want to find a real libncurses.so.4 and install it rather
than symlinking libncurses.so.5 to it.  You probably will be able to
get away with the symlink, but changes in major revs (4->5) tend to
indicate significant changes in parts of the interface (API), which
would cause the caller great consternation if it was unlucky and called
a function whose interface had changed.


At 07:32 AM 9/20/01 -0700, Dan Bethe wrote:

> > I have already libncurses.so.5.2
> >
> > So I tried as below, but I had the same result.
> > ---------------------------------------------------
> > # ln -s libncurses.so.5.2 libncurses.so.4
> > # rpm -ivh cscope-15.3-1.i386.rpm
> > error: failed dependencies:
> >         libncurses.so.4 is needed by cscope-15.3-1
>         Hi there.  RPM's dependancies are based on its database, and
> not on the actual
>filesystem.  So the 'ln' wouldn't make any difference in this
>case.  Try this:
># rpm -ivh --nodeps cscope-15.3-1.i386.rpm
>         That bypasses RPM's opinion of what is and should be
> installed, so you might
>always have to remember that as a one-off.
>Medium System Administrator and Junior I.T. Manager of 5 yrs
>  -- Now available -- Linux, MacOS, Unix-like systems
>     -- http://mmmgood.net -- dan_bethe at yahoo.com

******************** Lawyer gibberish: ********************

** Sent via the linuxppc-dev mail list. See http://lists.linuxppc.org/

More information about the Linuxppc-dev mailing list