Tom Rini trini at
Thu Nov 29 10:43:06 EST 2001

On Thu, Nov 29, 2001 at 09:07:12AM +1100, Paul Mackerras wrote:
> I want to rename CONFIG_ALL_PPC to CONFIG_PREP_PMAC_CHRP in the
> linuxppc_2_4_devel tree (or if anyone can suggest a better name I'll
> use that).
> Does anyone object to this?

Yes.  For historical note, the old 2_5 tree had CONFIG_WORKSTATION_PPC,
which suited most people.  But there's the fact that most of the
7xx/74xx boards in _devel now can take a video card and be a
'workstation' too. :)

How about we don't do this in 2_4 (or 2_4_devel) at all since it'll be a
bit of a maintance headache (2.4.x, x <= A is CONFIG_ALL_PPC, > A might
be XXX or ALL_PPC, and >= B it got into, ick..).

Perhaps we could even go as far as doing CONFIG_OPENFIRMWARE_PPC for
chrp/pmac/pop, bring back CONFIG_PREP for 'PReP', and work on doing
plaform support along the lines of Y/N instead of group A, B, or C.

Or barring all of that messy work, CONFIG_COMMON_PPC :)

Tom Rini (TR1265)

** Sent via the linuxppc-dev mail list. See

More information about the Linuxppc-dev mailing list