Undefined symbols that are in System.map?

Jeff Rugen jprugen at earthlink.net
Thu Jul 12 01:32:08 EST 2001

I have a 2.2.20pre6 kernel (from vger.samba.org rsync). I've compiled the
clgen framebuffer as a module, and have the VGA console built in.  When I
try to modprobe clgenfb, I am notified that vga_con and conswitchp are
unresolved, so the various fbcon-cfb*.o modules won't install. fbgen.o will
install manually.

vga_con and conswitchp are both in my System.map file:
c017ac94 D vga_con
c017b22d D conswitchp

When I run 2.4.6, compiled with a VGA console built in, and clgen as a
module, it allows me to modprobe clgenfb.  That System.map file looks like:
c0146554 R vga_con
c01ba4d4 B conswitchp

I'm noting them both because of the difference in location of the symbols
(uninitialized data, initialized data, read only data).  What would be
causing this?  I haven't tried ignoring the errors.


Jeff Rugen

** Sent via the linuxppc-dev mail list. See http://lists.linuxppc.org/

More information about the Linuxppc-dev mailing list