Building X 3.3.6 (non-distributor environment)

Michel Dänzer michdaen at
Sat Apr 8 20:12:09 EST 2000

"Michael A. Peters" wrote:
> I'm running the Linux From Scratch project
> ( and its all working swell except X
> won't build.
> When I unpack X3.3.6 and try "make World" it very quickly quits with
> an error from gcc. Funny thing is, the build *does* complete under
> LinuxPPC (gcc 2.95.2, glibc 2.1.3 if it matters) from the same source.
> Opinion among people who have used the LFS howto on x86 and also
> built X on other platforms is that my problem is that the make World
> script doesn't know my compiler is gcc. Yes, I do have cc symlinked
> to gcc
> I've even tried make CC=gcc World with same result.
> However, under LinuxPPC it compiles no problem.
> Any of you know what the problem is (if its something else) or how to
> set up the non-distribution linux so that it DOES know the compiler
> is gcc?

In xc/config/cf there's a bunch of config files, the important ones for you
are probably and

Set everything concerning Gcc (and maybe other stuff as well) to reflect your
system and you should be fine.


** Sent via the linuxppc-dev mail list. See

More information about the Linuxppc-dev mailing list