SMP support for Daystar 604e 200MHz dual-processor card

David D. Kilzer ddkilzer at
Wed Sep 1 12:59:31 EST 1999

Michel Lanners wrote:

>> Serial driver version 4.27 with no serial options enabled
>  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
>> Machine check in kernel mode.
>This might be a shot in the dark, but I never heard of anyone
>successfully compiling in standard serial support on the PowerMacs. I
>tried it myself; I would get a panic upon initializing the serial
>driver (exactly like above..).
>So you might want to disable standard serial suport, and recompile...

Yes!  Thanks for all the help!  This was the problem.  I removed
CONFIG_SERIAL and it booted!

Unfortunately, I still get a "Processor 1 stuck." message on boot, which
apparently makes it absent from /proc/cpuinfo as well.  This is booting
from the BootX application in Mac OS (with or without extensions loaded).

I haven't tried booting from OF or with the BootX extension yet.

Thanks again for all the help!!  (Anyone get 2.3.x to boot with SMP? :^)


[[ This message was sent via the linuxppc-dev mailing list.  Replies are ]]
[[ not  forced  back  to the list, so be sure to Cc linuxppc-dev if your ]]
[[ reply is of general interest. Please check ]]
[[ and for useful information before posting.   ]]

More information about the Linuxppc-dev mailing list