Success with MVME2306 and MVME2600

Michael Lundkvist ml at
Mon Mar 15 07:23:02 EST 1999

Finally! :)

I have sucessfully booted Linux on some of our MVME-cards.

I'll try to outline my procedure in the hope that it will help others.

My first attempts where on a MVME2307 with a DEC 21143 ethernet chip.
I initially used Gabriel Pauberts kernels with preploader. My first
problem was that I hadn't enabled PReP boot mode with ENV.

Network PReP-Boot Mode Enable [Y/N] = Y?

Gabriel pointed this out to me and I got a bit further. The next snag
was another setting in ENV.

VME3PCI Master Master Enable [Y/N] = N?

David De Ridder helped me with this one. After that the kernel crashed 
when trying to initialize eth0. I found out that this was a known
problem so I switched to a MVME2306 with a DEC21140.

Success! The kernel booted and tried to mount the nfsroot. I used the 
following bootarguments to set IP-adresses without using bootp.


Now I needed a root filesystem. I made this by installing RPMs from R5 
of the LinuxPPC release from a Linux x86 box. There where a few
problems. First there was the magic --initdb switch to rpm to get it
to create rpm databases. Then there was the fact that all
installscripts failed because of the different architecture. Luckily
most of the scripts could be performed by hand or ignored.

When I tried to boot the next time the card was able to mount it's
root but failed to open the console. This was because the dev-package
creates /dev/console with major 4 minor 0 and the kernel wants major
5 minor 1.

After that I was up and kicking!

My next step was to compile a kernel with both nfsroot support and
SCSI-support. I used a stock 2.2.1-kernel and patched it with Gabriels 
mvme2600.generic-patch-2.2.1. I hade to change a reference to
powermac_init() into ppc_init() in init/main.c. 

This kernel booted fine on a MVME2604-card and detected the

I then was confused about how to partion the disk until I discovered
the trusty old fdisk in /sbin. :)

After that I copied my nfsdirectory onto the disk and rebooted. Gave
root=/dev/sda2 as an argument to the loader and I had a working

This is great! It's pure joy compared to the VxWorks-cruft that these
cards ran before. Great work! Thanks!

I have begun to try to figure out why the 2307 card won't work and it
looks like there is no interupt routing information for the DEC21143
in the residual data. I'll post more when/if I find out.

Will the preploader be merged with the vger CVS anytime soon?



Michael Lundkvist
Epact Technology AB
ml at

[[ This message was sent via the linuxppc-dev mailing list.  Replies are ]]
[[ not  forced  back  to the list, so be sure to Cc linuxppc-dev if your ]]
[[ reply is of general interest. Please check ]]
[[ and for useful information before posting.   ]]

More information about the Linuxppc-dev mailing list