SMP support for Daystar 604e 200MHz dual-processor card

David D. Kilzer ddkilzer at
Mon Aug 30 15:54:50 EST 1999


Is anyone running LinuxPPC with a Daystart 604e 200MHz dual-processor card?

I've compiled 2.2.12 from CVS source, and the kernel oops with some sort of
MMU fault.  (I can print out the exact error if necessary.)

I've also compiled 2.3.15 from CVS source, but it doesn't even get past the
initial screen that ends with "booting...".

Both kernels had SMP support compiled in.  I have not tried compiling a
kernel without SMP.

I'm using BootX 1.1.3 with only my root partition (/dev/sdb9) defined.

I have a working MkLinux installation (using glibc 2.0) with the
pmac-utils-1.1.1-1a.ppc.rpm installed (rebuilt from source) that boots fine.

Any ideas?  I haven't tried adding debug code or perusing the source, yet,
but I expected this configuration to work out-of-the-box since Daystar and
Apple SMP cards are supposed to be essentially the same.



[[ This message was sent via the linuxppc-dev mailing list.  Replies are ]]
[[ not  forced  back  to the list, so be sure to Cc linuxppc-dev if your ]]
[[ reply is of general interest. Please check ]]
[[ and for useful information before posting.   ]]

More information about the Linuxppc-dev mailing list