[Patch] linuxppc gnuplot segfaults in save

Franz Sirl Franz.Sirl at munich.netsurf.de
Thu Apr 15 19:16:31 EST 1999

At 08:54 15.04.99 , Martin Costabel wrote:
>> > Or could someone find out what's wrong with the fprintf function in
>> > LinuPPC? Note that this is not specific for one version of glibc. I
>> > tried it on several from glibc-961212 to glibc-2.1.1-3a. Same result.
>> It failed under the old libs?
>Yes, I compiled gnuplot-3.7 under glibc-961212 (rev 1o, IIRC), and the
>result was the same. I managed to track the problem down to the fprintf
>call, but I don't know enough C and glibc to go any further.

The problem could be egcs, there's a known varargs bug on PPC, which 
happens as soon you have more than 8-10 args. There's a testcase for this 
in the egcs testsuite, gcc.c-torture/execute/980608-1.c, which still fails 
in the development sources. I hope this will be resolved for egcs-1.2 if 
the rewrite of the function epilogue/prologue to use RTL makes it in time...


[[ This message was sent via the linuxppc-dev mailing list.  Replies are ]]
[[ not  forced  back  to the list, so be sure to Cc linuxppc-dev if your ]]
[[ reply is of general interest. Please check http://lists.linuxppc.org/ ]]
[[ and http://www.linuxppc.org/ for useful information before posting.   ]]

More information about the Linuxppc-dev mailing list