[PATCH v2 04/22] mtd: spi-nor: Rename nor->params to nor->flash

Tudor.Ambarus at microchip.com Tudor.Ambarus at microchip.com
Thu Oct 24 08:34:39 AEDT 2019

On 10/10/2019 10:05 AM, Boris Brezillon wrote:
> External E-Mail
> On Tue, 24 Sep 2019 07:46:03 +0000
> <Tudor.Ambarus at microchip.com> wrote:
>> From: Tudor Ambarus <tudor.ambarus at microchip.com>
>> Rename nor->params to nor->flash for a clearer separation
>> between the controller and flash operations.
> Hm, I'm not sure 'flash' is clearer than 'params', and the spi_nor
> object is supposed to represent the NOR chip anyway, so it was pretty
> clear to me that nor->params were the NOR flash parameters not the
> NOR controller ones.
> If I had anything to change it would be s/params/properties/ (and
> s/spi_nor_flash_parameter/spi_nor_properties/) since those parameters
> look like immutable information discovered during the NOR detection,
> but I'm nitpicking here.

I'll drop this for now.

More information about the Linux-aspeed mailing list