[PATCH v2 04/22] mtd: spi-nor: Rename nor->params to nor->flash

Boris Brezillon boris.brezillon at collabora.com
Thu Oct 10 18:05:24 AEDT 2019

On Tue, 24 Sep 2019 07:46:03 +0000
<Tudor.Ambarus at microchip.com> wrote:

> From: Tudor Ambarus <tudor.ambarus at microchip.com>
> Rename nor->params to nor->flash for a clearer separation
> between the controller and flash operations.

Hm, I'm not sure 'flash' is clearer than 'params', and the spi_nor
object is supposed to represent the NOR chip anyway, so it was pretty
clear to me that nor->params were the NOR flash parameters not the
NOR controller ones.
If I had anything to change it would be s/params/properties/ (and
s/spi_nor_flash_parameter/spi_nor_properties/) since those parameters
look like immutable information discovered during the NOR detection,
but I'm nitpicking here.

More information about the Linux-aspeed mailing list