[RFC PATCH v3 1/5] dt: add of_get_child_count helper function
Stephen Warren
swarren at nvidia.com
Wed Dec 21 10:58:43 EST 2011
Dong Aisheng wrote at Tuesday, December 20, 2011 10:41 AM:
> From: Dong Aisheng <dong.aisheng at linaro.org>
>
> Currently most code to get child count in kernel are almost same,
> add a helper to implement this function for dt to use.
> diff --git a/include/linux/of.h b/include/linux/of.h
> +static inline int of_get_child_count(const struct device_node *np)
> +{
> + return -ENOSYS;
> +}
Wouldn't it be better to return 0 here? -ENOSYS would be fine if the
function returned an error code, but it's really returning a count, and
other "dummy" functions that return data return 0/NULL already. This
would also allow you to just use the value directly in all cases rather
than having to check for a < 0 error case.
--
nvpublic
More information about the devicetree-discuss
mailing list