[Cbe-oss-dev] [PATCH 6/10] MARS: workload queue schedule initialize wait id

Yuji Mano Yuji.Mano at am.sony.com
Thu Aug 7 04:25:59 EST 2008


Geert Uytterhoeven wrote:
> On Tue, 5 Aug 2008, Yuji Mano wrote:
>> Use defined macro instead of magic number when initializing workload wait state.
>> 
>> Signed-off-by: Yuji Mano <yuji.mano at am.sony.com>
>> 
>> ---
>>  src/host/lib/mars_workload_queue.c |    1 +
>>  1 file changed, 1 insertion(+)
>> 
>> --- a/src/host/lib/mars_workload_queue.c
>> +++ b/src/host/lib/mars_workload_queue.c
>> @@ -180,6 +180,7 @@ int workload_queue_schedule(struct mars_
>>  	queue->block[block].priority[index] = priority;
>>  	queue->block[block].counter[index] = 0;
>>  	queue->block[block].signal[index] = 0;
>> +	queue->block[block].wait[index] = MARS_WORKLOAD_ID_NONE;
>>  
>>  	return MARS_SUCCESS;
>>  }
> 
> There's no `instead of magic number' part?

Oops. You are right. I think I got into copy paste mode.

Regards,
Yuji




More information about the cbe-oss-dev mailing list