[Cbe-oss-dev] [PATCH 6/10] MARS: workload queue schedule initialize wait id

Geert Uytterhoeven Geert.Uytterhoeven at sonycom.com
Wed Aug 6 19:25:57 EST 2008


On Tue, 5 Aug 2008, Yuji Mano wrote:
> Use defined macro instead of magic number when initializing workload wait state.
> 
> Signed-off-by: Yuji Mano <yuji.mano at am.sony.com>
> 
> ---
>  src/host/lib/mars_workload_queue.c |    1 +
>  1 file changed, 1 insertion(+)
> 
> --- a/src/host/lib/mars_workload_queue.c
> +++ b/src/host/lib/mars_workload_queue.c
> @@ -180,6 +180,7 @@ int workload_queue_schedule(struct mars_
>  	queue->block[block].priority[index] = priority;
>  	queue->block[block].counter[index] = 0;
>  	queue->block[block].signal[index] = 0;
> +	queue->block[block].wait[index] = MARS_WORKLOAD_ID_NONE;
>  
>  	return MARS_SUCCESS;
>  }

There's no `instead of magic number' part?

With kind regards,

Geert Uytterhoeven
Software Architect

Sony Techsoft Centre Europe
The Corporate Village · Da Vincilaan 7-D1 · B-1935 Zaventem · Belgium

Phone:    +32 (0)2 700 8453
Fax:      +32 (0)2 700 8622
E-mail:   Geert.Uytterhoeven at sonycom.com
Internet: http://www.sony-europe.com/

A division of Sony Europe (Belgium) N.V.
VAT BE 0413.825.160 · RPR Brussels
Fortis 293-0376800-10 GEBA-BE-BB


More information about the cbe-oss-dev mailing list