[Cbe-oss-dev] Problems building the ps3-linux branch

Geoff Levand geoffrey.levand at am.sony.com
Fri Mar 16 02:34:03 EST 2007

Julio M. Merino Vidal wrote:
> OK, I've been testing the kernel today.  It seems to boot fine with  
> your fix, but I've been unable to get the YDL5 installation on the  
> PS3 to start with the updated kernel.

YDL has a know problem in its startup scripts.  I recommend you use
FC5 to start.  See:


After that is working for you, think about FC6 since I don't use FC5

> I've done a lot of tests, but the one that seems more "correct" is this:
> I built the ps3-linux branch by using the ps3_defconfig as is,  
> without any changes.  Then I ran "make targz-pkg".  I copied the  
> resulting file, linux-2.6.21-rc3-g6a692aee-dirty.tar.gz, to the PS3,  
> where I unpacked it in a temporary directory.
> I put the modules in place and copied the vmlinux image to /boot/ 
> vmlinux-jmerino.  I then created a new initrd by using "mkinitrd / 
> boot/initrd-jmerino.img 2.6.21-rc3-g6a692aee-dirty" and added an  
> entry to /etc/kboot.conf.  I mimic'ed the one for ydltext but  
> replacing the version numbers with "jmerino", which is:

If you plan to do development work with the kernel I recommend you
set up an NFS root file system:


Then build with something like 

ARCH=powerpc CROSS_COMPILE='ccache /opt/cell/toolchain-3.3/bin/ppu-' INSTALL_MOD_PATH=/target/tool INSTALL_PATH=/target/tool/boot && cp arch/powerpc/buld/zImage.ps3 /target/tool/boot zImage

> jmerino='/dev/sda1:/vmlinux-jmerino initrd=/dev/sda1:/initrd- 
> jmerino.img root=/dev/sda2 init=/sbin/init 3'
> Then, the kernel starts up but when it is time to exec init, it says:
> Warning: Unable to open an initial console.

This is because YDL is setup for the 2.6.16 legacy kernel.

Try (on the ps3):

cd /dev

MAKEDEV console

> I've also tried multiple other things, such as 1. building a kernel  
> without modules support and keeping everything in it, 2. not using an  
> initrd at all, or 3. reusing the initrd for the default YDL5 kernel.   
> All tests failed with the above or with a message saying that the  
> kernel could not find init (even though it seemed to correctly mount  
> the root partition).
> I'm not sure why this is failing, nor have been able to find a  
> solution.  Any clue?

As above.

> PS: Is it there any other mailing list more suitable for "Linux on  
> PS3" questions or this one is fine?

Much of this is really not PS3 specific.  Try some general Linux
development resources.  Anyway, good luck with it.


More information about the cbe-oss-dev mailing list