[Cbe-oss-dev] Problems building the ps3-linux branch

Julio M. Merino Vidal jmerino at ac.upc.edu
Fri Mar 16 00:22:26 EST 2007

On 14/03/2007, at 21:36, Julio M. Merino Vidal wrote:

> On 14/03/2007, at 20:12, Geoff Levand wrote:
>> Julio M. Merino Vidal wrote:
>>> I'm cross-building from a Fedora Core 6 i386 system by using the  
>>> ppu-
>>> gcc distributed with the Cell SDK 2.0.  So, I've "ARCH=powerpc" and
>>> "CROSS_COMPILE=ppu-" on the top-level Makefile.
>>> Unfortunately, when building the kernel, the process bombs out in  
>>> the
>>> ps3-hvcall.S file.  The attached log contains more details.
>> The version of binutils (2.16.1) in SDK 2.0 doesn't support the  
>> ':req'
>> macro construct.
>> I pushed this fix (d816b513b) to kernel.org, but it will take a
>> while for it to propagate to the mirrors.
> Excellent; thank you very much.
> The kernel now builds for me.  Will confirm whether it works on not  
> when I get to the university tomorrow morning.

OK, I've been testing the kernel today.  It seems to boot fine with  
your fix, but I've been unable to get the YDL5 installation on the  
PS3 to start with the updated kernel.

I've done a lot of tests, but the one that seems more "correct" is this:

I built the ps3-linux branch by using the ps3_defconfig as is,  
without any changes.  Then I ran "make targz-pkg".  I copied the  
resulting file, linux-2.6.21-rc3-g6a692aee-dirty.tar.gz, to the PS3,  
where I unpacked it in a temporary directory.

I put the modules in place and copied the vmlinux image to /boot/ 
vmlinux-jmerino.  I then created a new initrd by using "mkinitrd / 
boot/initrd-jmerino.img 2.6.21-rc3-g6a692aee-dirty" and added an  
entry to /etc/kboot.conf.  I mimic'ed the one for ydltext but  
replacing the version numbers with "jmerino", which is:

jmerino='/dev/sda1:/vmlinux-jmerino initrd=/dev/sda1:/initrd- 
jmerino.img root=/dev/sda2 init=/sbin/init 3'

Then, the kernel starts up but when it is time to exec init, it says:

Warning: Unable to open an initial console.

I've also tried multiple other things, such as 1. building a kernel  
without modules support and keeping everything in it, 2. not using an  
initrd at all, or 3. reusing the initrd for the default YDL5 kernel.   
All tests failed with the above or with a message saying that the  
kernel could not find init (even though it seemed to correctly mount  
the root partition).

I'm not sure why this is failing, nor have been able to find a  
solution.  Any clue?

Thank you!

PS: Is it there any other mailing list more suitable for "Linux on  
PS3" questions or this one is fine?

Julio M. Merino Vidal <jmerino at ac.upc.edu>

More information about the cbe-oss-dev mailing list