yaboot kicked my butt... (5 times?!)

Mark Knecht markknecht at gmail.com
Thu Sep 23 08:27:53 EST 2010

   OK, I'm dead tired. I admit it - yaboot has kicked my butt this
time around. Can anyone help?

   The machine is the original 80GB PPC Mac Mini. I used to run Gentoo
on it and it ran great for years so I know at one time yaboot worked
just fine. For various reasons I hadn't updated it in a long, long
time (2 years) and instead of trying to go through the Gentoo update
process which is difficult after that much time I decided to just do a
new install. I saved copies of my kernel config and etc/make.conf but
unfortunately, being primarily an x86 guy didn't think to save
yaboot.conf and fstab. I've now done 5 complete Gentoo installs,
starting over from scratch in case something I was doing was messing
things up but so far I cannot get the machine to boot. Every time, no
matter what I do at install time, I get a message

"Can't check if filesystem is mounted due to a missing mtab file"

A somewhat out of focus screen shot is shown here:


Generally speaking I'm following the Gentoo PPC install guide located here:


I've tried both the yabootconfig method as well as manual route.
Nothing works for me so far.

It's not in the photo but all the way through the boot the kernel
calls the hard drives /dev/hda so I'm assuming that's correct in

The kernel is 2.6.34-gentoo-r2 and the kernel config file is attached.
ext3 is built into the kernel so that shouldn't be a problem.

As a _hardware_ test I reinstalled the old OS X that came with the
machine and it boots fine. I blew it away and installed Ubuntu 10.04
for the PPC and it boots fine, but Ubuntu uses and initrc which I've
never used before with Gentoo. (And why on this machine as the
hardware is fixed has kernel drivers.)

I'm a long time Gentoo user. The main Gentoo install seems to work
fine on this machine. As best I can tell it's only the yaboot stuff
not booting that's holding me up from using this little machine again.

Can anyone see what I've done wrong?


livecd ~ # mount /dev/hda4 /mnt/gentoo
livecd ~ # mount -t proc none /mnt/gentoo/proc
livecd ~ # mount -o bind /dev /mnt/gentoo/dev
livecd ~ # mount -o bind /sys /mnt/gentoo/sys
livecd ~ # chroot /mnt/gentoo /bin/bash
livecd / # env-update
>>> Regenerating /etc/ld.so.cache...
livecd / # source /etc/profile
livecd / # export PS1="(chroot) $PS1"
(chroot) livecd / # cat /etc/yaboot.conf

#device=/pci at f4000000/ata-6 at d/disk at 0:

(chroot) livecd / # mac-fdisk -l /dev/hda
        #                    type name                  length   base
    ( size )  system
/dev/hda1     Apple_partition_map Apple                     63 @ 1
    ( 31.5k)  Partition map
/dev/hda2         Apple_Bootstrap bootstrap               1600 @ 64
    (800.0k)  NewWorld bootblock
/dev/hda3         Apple_UNIX_SVR2 swap                 2097152 @ 1664
    (  1.0G)  Linux swap
/dev/hda4         Apple_UNIX_SVR2 root               154202672 @
2098816   ( 73.5G)  Linux native

Block size=512, Number of Blocks=156301488
DeviceType=0x0, DeviceId=0x0

(chroot) livecd / # cat /etc/fstab
/dev/hda4   /            ext3    noatime              0 1
/dev/hda3   none         swap    sw                   0 0

/dev/cdrom  /mnt/cdrom   auto    noauto,user          0 0

proc        /proc        proc    defaults             0 0
shm         /dev/shm     tmpfs   nodev,nosuid,noexec  0 0
(chroot) livecd / # ybin -v
ybin: Finding OpenFirmware device path to `/dev/hda2'...
ybin: Installing first stage bootstrap /usr/lib/yaboot/ofboot onto /dev/hda2...
ybin: Installing primary bootstrap /usr/lib/yaboot/yaboot onto /dev/hda2...
ybin: Installing /etc/yaboot.conf onto /dev/hda2...
ybin: Setting attributes on ofboot...
ybin: Setting attributes on yaboot...
ybin: Setting attributes on yaboot.conf...
ybin: Blessing /dev/hda2 with Holy Penguin Pee...
ybin: Updating OpenFirmware boot-device variable in nvram...
(chroot) livecd / # ls -al /boot/kernel*
-rwxr-xr-x 1 root root 5547992 Sep 22 11:06 /boot/kernel-2.6.34-gentoo-r1
(chroot) livecd / # exit
livecd ~ # umount /mnt/gentoo/proc /mnt/gentoo/dev /mnt/gentoo/sys /mnt/gentoo
livecd ~ #
livecd ~ #
-------------- next part --------------
A non-text attachment was scrubbed...
Name: MacMini.config
Type: application/octet-stream
Size: 56021 bytes
Desc: not available
URL: <http://lists.ozlabs.org/pipermail/yaboot-users/attachments/20100922/58534435/attachment-0001.obj>

More information about the Yaboot-users mailing list