Debian PowerPc installer initramfs-tools generates malformed yaboot.conf created when alternate partitions use UUID= in fstab

Benjamin Cama benoar at
Mon Jun 28 09:21:02 EST 2010


Le dimanche 27 juin 2010 à 15:30 -0400, Rick Thomas a écrit :
> This is reported as Debian bug #587290 -- please followup to the bug  
> report.
> The generated /etc/yaboot.conf contains lines
> 	append="root=UUID ro"
> for partitions that have their /etc/fstab root line using "UUID=... " .
> This makes it impossible to boot into those partitions:
>   the boot progresses to the point of trying to mount the root
>   filesystem and dies with
> 	Begin: Running /scripts/local-premount ... done
> 	Mount: mounting UUID on /root failed: No such directory
>   then a few more errors obviously caused by not having a mounted root
>   and eventually dropping into the (initrd) BusyBox shell.
> When I went back and changed the offending line to
> 	append="root=/dev/hda6 ro"
> and reran ybin, everything was fine.
> See bug # 580455 for another aspect of the switch to UUID naming being
> broken on powerPC.

Thanks Rick for your perseverance, I hope this kind of bug could get
solved more easily, but from what I *personally* realized :
- maintenance of yaboot has always been "flacky" in the sense that
maintainers seem to get hopeless on the lack of interest/motivation from
powerpc devs/users
- there are currently no DD that care about powerpc problems (or we
could rather say that no people who care about PPC are DDs)

I wanted to help for a problem with the buildd but Frans Pop told us
that it needed a DD to be solved, and I also have a patch for util-linux
specific to PPC that is waiting for monthes. But there are only users
and simple developers left on the debian-powerpc ML, so we're a bit
alone and hopeless ...

Still, you're right that dropping ppc support for Lenny would be sad, so
I may have a look a this, but being so close to the solution (as you
were too when sending a patch for the second bug you described) just to
be left without any news from anyone is a bit discouraging.


More information about the Yaboot-users mailing list